プロフィール

カレンダー

2019 年 03 月

2月<  > 4月

          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31            

menber

コミュニティ名 クローバー
参加条件 どなたでも参加できます
カテゴリー ゼミ・サークル・クラブ活動
開始日 05年06月23日02:54
管理人 admin
コミュニティの説明 クローバー管理者が主催する公式サイト。ご質問、ご意見、ご感想をどしどし投稿してください。
RSS

バグコーナー

バグを発見しましたらコメントに投稿お願いします。 出来るだけすばやく対応させていただきます。 なおバグのFIX状況については、次のURLで公開します。 https://clover.h555.net/u/koyama/?y=&m=&d=&ca1=29

投稿者 : admin  |  2005年 07月 23日 14:08  |  Comments ( 25 )

コメント

はじめまして。
トラックバックが入ると「clover.h555.netからお知らせ」がメールにやってくるのですが、どうも2通届いているようです。
1通目は【BLOG_NAME】・【タイトル】・【概要】・【URL】が空っぽで、2通目は、ちゃんと内容が入っています。
最近になって、初めてトラックバックを受けたもので、今まで気づきませんでした。

投稿者 : KEISUKE /  2005年 12月 09日 21:22

コミュニティが表示できなくなったのですが、何か変わったのでしょうか。ここのコミュニティは、文字化けした後エンコードを換えれば表示できました。

投稿者 : ふくろう兄さん /  2005年 09月 23日 22:17

JavaScriptによるタグの挿入ですが、Win版IE以外(?)ではボタンを押した瞬間に document.selection が空になってしまいます。
ですが、textarea オブジェクトの selectionStart,selectionEnd は残ったままであることが多いので、
document.selection が空なら textareaオブジェクトの
"0からselectionStart" + "<tag>" + "selectionStartからselectionEnd" + "</tag>" + "selectionStartから最後"
を textareaオブジェクトの value に設定する。
ってなことをするのが定石です。
selectionStart, selectionEnd が残らないブラウザに関してはどうしようもないので未対応と明記するようです。(Safariはこれにあたります。)
JavaScriptによるタグの挿入ですが、Win版IE以外(?)ではボタンを押した瞬間に document.selection が空になってしまいます。
ですが、textarea オブジェクトの selectionStart,selectionEnd は残ったままであることが多いので、
document.selection が空なら textareaオブジェクトの
"0から selectionStart" + "<tag>" + "selectionStart から selectionEnd" + "</tag>" + "selectionStart から最後"
を textarea オブジェクトの value に設定する。
ってなことをするのが定石です。
selectionStart, selectionEnd が残らないブラウザに関してはどうしようもないので未対応と明記するようです。(Safari はこれにあたります。)
img タグに関しては、無理矢理 textarea オブジェクトの value の最後に追記することで、未対応ブラウザにもとりあえず画像の URL を渡せるように出来ます。

投稿者 : masaki /  2005年 09月 08日 00:37

masaki様のコメントに対する返信

申し訳ございません。ブラウザの検証を随時実施しております。
コンテンツ登録につきましては、次の代替方法で実施頂きたくお願いします。

画像の挿入
画像を入れたいところに次のタグを記入お願いします。
ファイル1の画像を、左寄せで挿入
ファイル1の画像を、中央寄せで挿入
ファイル1の画像を、右寄せで挿入
ファイル2の画像を、左寄せで挿入
ファイル2の画像を、中央寄せで挿入
ファイル2の画像を、右寄せで挿入

改行


強調
強調したい文字列

リンク
文字列

メール
文字列

見出し
文字列

引用
文字列

投稿者 : admin /  2005年 09月 06日 19:34

そろそろ、Mac に対応してくれませんか?

投稿者 : masaki /  2005年 09月 05日 00:15

お早うございます。「友だち編集」の頁が何故かバグってしまってます。ご確認願います。

投稿者 : やまと /  2005年 08月 11日 10:18

Reptile様のコメントに対する返信
セッションタイムアウトの時間を長く致しました。これで、まず切れることは無いと思います。

投稿者 : admin /  2005年 08月 04日 09:20

仰るとおり、セッションタイムアウトのタイミングです。 ベーシック認証を最初の一回だけとっていらっしゃるのだと思いますが、セッションタイムアウト時の動作が問題だと思います。 今の動きでは、再度認証要求を出した後はアップロード要求を放棄して初期画面表示に行ってしまっています。事前の要求を保持する様改善されのが得策ではないでしょうか。

投稿者 : Reptile /  2005年 08月 01日 02:21

ふくろう兄さん様のコメントに対する返信   2枚の写真をUPするとNoImageになる件、申し訳ございません。バグでした。修正完了しております。友人申請は、通常のメールとしては届きません。お友達編集のところに掲載されます。

投稿者 : admin /  2005年 08月 01日 01:04

kaoru様のコメントに対する返信   いろいろ再現テストを試みましたが、通常の環境では再発しませんでした。考えられる可能性は、セッションタイムアウトを起こしたか、別ウインドウでセッションを切ったかです。投稿の画面を開き、UPするまで時間がかかると、セッションタイムアウトになってしまいご指摘の現象になります。

投稿者 : admin /  2005年 08月 01日 00:24

友達申請のメールが届いていないらしいのですが、これって特定の人に届かない場合があるのでしょうか。sacchiさんに確認したら届いていないということでしたよ。地球情報化に懸けた男さんにも申請してたんだけど反応がなかったので、てっきり拒否されたと思って申請取り消ししたんだけど。。。

投稿者 : ふくろう兄さん /  2005年 07月 31日 08:46

ブログで写真を二枚添付するとブログresultでNo imageになるのは、どうしてでしょうか?一枚目を選択して表示するというのはできますか?

投稿者 : ふくろう兄さん /  2005年 07月 30日 21:26

親分、これは痛いっす! ブログの新規投稿分の編集中に深夜を跨いだせいだと思うのですが、SUBMITボタンを押した途端再度Loginの要求が表示され、挙句の果てに編集中の内容は全部フラッシュされ何処にも残っていません.. 殺生でっせ(ToT)

投稿者 : kaoru /  2005年 07月 29日 00:27

kaoru様のコメントに対する返信       ご指摘ありがとうございます。修正いたしました

投稿者 : admin /  2005年 07月 28日 01:18

親分、ご無沙汰してます。 早速ですが、害虫を見つけました。 ブログテンプレートの編集時、「ブログの名前」や「ブログの説明」を入力せずにsubmitを押すと、エラーが出ますが、その後「ブログテンプレートの選択」の選択肢が表示されなくなり、エラーから抜け出せません。キャンセルすればイニシャライズされので、当然ループから抜け出せますが.. 宜しくお願いします。

投稿者 : kaoru /  2005年 07月 27日 19:21

masaki様のコメントに対する返信   修正が完了しました。ご確認お願いします。

投稿者 : admin /  2005年 07月 27日 01:08

マニュアルとヘルプ見られるようになりましたよ。どこか修正されたのですね。ありがとうございます。

投稿者 : ふくろう兄さん /  2005年 07月 26日 09:06

やまと様のコメントに対する返信   ありがとうございました。修正いたしました。

投稿者 : admin /  2005年 07月 26日 03:13

友だち紹介に投稿したのに反映されないみたいです。。。

投稿者 : やまと /  2005年 07月 25日 20:23

masakiさんと同じくマニュアルやヘルプがほんの一瞬だけ表示されて真っ白になります。以前少しの間だけ表示できてたんですけど。設定をあれこれいじったためか何が原因かわからなくなってます。

投稿者 : ふくろう兄さん /  2005年 07月 25日 09:15

下の部分に関してですが、マニュアルページには件のタグが入ってはいますが、その前に改行コードが入っているため、うちのだめブラウザ(Safari)ではちゃんと認識してくれません。 規格上 <?xml はデータの先頭になければなりません。

投稿者 : masaki /  2005年 07月 25日 01:10

https://clover.h555.net/f/koyama のような個別のプロフィールページに <?xml version="1.0" encoding="EUC-JP"?> の行が含まれてませんね。

投稿者 : masaki /  2005年 07月 25日 00:47

お世話になります。今、原因がわかりました。エンコードの自動選択にチェックが入っていると、TOPページで日本語(シフトJIS)を選択して文字化けしてしまったり、別のページで表示されない場合があるのです。お騒がせしました。ちなみにIEのバージョンは6です。フリーソフトの影響もあるのかもしれません。

投稿者 : ふくろう兄さん /  2005年 07月 24日 00:15

ふくろう兄さん様のコメントに対する返信   本システムは日本語(EUC)を使ってます。ブラウザーは自動で日本語(EUC)を設定されるはずです。ブラウザーの詳細(名称、Ver)を開示頂ければ詳細調査いたします。

投稿者 : admin /  2005年 07月 23日 23:40

エンコードについて、シフトJISを選択して文字化けするのはバグでしょうか。更新すれば正常に認識するのですが、TOPページは日本語(自動選択)か日本語(EUC)を選択しないと文字化けが直りません。。。IEでも他のブラウザでも同じです。

投稿者 : ふくろう兄さん /  2005年 07月 23日 17:53

コメントを投稿する

名前

メールアドレス

URL

コメント


※規約に同意の上 コメント投稿を行ってください。